Titan 875 intermittent runs rough

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
I have a Titan 875 with the gm Vortec engine. 1400 hrs. I also have a Thermalwave same engine same hours but the engine always runs smoothly. The Titan will start up fine and run great for about 20 min then as best as I can describe starts to stumble, bog down or missing. In the past I would just turn it off give it a few minutes start up again it would run fine for a bit . I would repeat this a few times and eventually it would smooth out after it ran a bit longer and then run for hours fine even on some all day jobs. But whenever it would be off for a bit I would go through the same thing. Especially when first getting it running beginning of the day.
a few weeks ago I was having an awful time getting past that usual start and stop till it smoothed out. I noticed the lower exhaust was cherry red diverter valve too and lower pipes . I figured I had a clogged catalytic and taped it a bit and eventually it smoothed out enough to finish an all day job and the exhaust stayed cool. Machine ran fine.
i went ahead and replaced the cat and made sure all the exhaust system was clear of any debris and yes the old caunit was crumbling inside the unit.
I figured this was the problem but on the next use the machine was doing the same thing but it would not smooth out even with the start stop routine. I kept an eye on the exhaust and it never turned cherry red or looked like any overheating.
Any ideas guys any help would be great.
of I was to start it now it would run fine for a bit like new.
 
  • Like
Reactions: gdulac and Mikey P

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
Appreciate the info so far. Like I mentioned the machine will run and at times for long period time when It finally smooths out. With my Thermalwave same engine as Titan 875 The cpu should just shut the machine down when it got hot. I found a loose plug wire not pushed all the way down today. I will try running it and see if that was it. I did manage to get some trouble codes from it with the engine light.
o2 sensors higher than limit and extra fuel code as well. Maybe the loose plug wire . I will keep you posted.
 
  • Like
Reactions: Cleanworks

BIG WOOD

The Timminator
Joined
Feb 4, 2016
Messages
13,412
Location
Georgia
Name
Matt w.
Do you think the corrosion from the Catalitic converter got blown into your fin heat exchanger and it's still getting clogged up? If that 875 is similar to my previous 575, it should be easy to pull out the fins and see if it needs cleaned
 
  • Like
Reactions: Jimmy L

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
Do you think the corrosion from the Catalitic converter got blown into your fin heat exchanger and it's still getting clogged up? If that 875 is similar to my previous 575, it should be easy to pull out the fins and see if it needs cleaned
I took the exchanger out to redo the box and it looked like new. I am also having the problem in the heat bypass mode as well that pushes exhaust infront of the heat exchanger core.
 

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
Update what looked like a loose plug wire doesn’t seem to be the problem. Quick recap. I had hollowed out the old cat while I waited on a new/used cat. During that time when I ran the machine it still stumbled and ran like it was bogged down but the exhaust tubing including the diverter valve did not get cherry red but it still stumbled like before . I later received a good used cat no debris in it honey comb looked clear I installed it and that’s when I found the loose spark plug wire. I ran the machine today with the replacement cat and the spark plug wire secured. Machine ran for about 15 min smooth then a slight stumble and then the same issue with bogged down. This time the exhaust and diverter valve cherry red.
I think I have two problems . I will take out the replacement cat an see it it fell apart it is a used one so maybe it fell apart and more junk in the system clogging up the exhaust and that probably why the cherry red exhaust. The really need some help .
8B20CB88-0281-4ABC-89C7-B8FE37AF7C38.jpeg
 

BIG WOOD

The Timminator
Joined
Feb 4, 2016
Messages
13,412
Location
Georgia
Name
Matt w.
I took the exchanger out to redo the box and it looked like new. I am also having the problem in the heat bypass mode as well that pushes exhaust infront of the heat exchanger core.
It seems that would be the location of where the blockage is. I remember that at some time, there was a defect in that bypass plate that was making it stick. And the 875 was in that year range
 

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
It seems that would be the location of where the blockage is. I remember that at some time, there was a defect in that bypass plate that was making it stick. And the 875 was in that year range
Yes I thought that too but the diverter valve is extremely smooth and it’s in the bypass mode anyway so I doubt it’s at the valve. I also just took off the replacement cat that was used and when I looked inside of it it is now damaged . I looked great when I put it in but it was used and someone took it out of another Machine for some reason. So probably not good.
I put the old one I had back it has been hollowed out and basically not cat . I ran the machine ant at about 10-15 minutes it Boggs but the exhaust is not turning cherry red. I does run a little better but that’s probably because of less resistance. What would cause a cat to get damaged like that anyone have any ideas. I also ran a snake camera in both ends of that exhaust system from the bypass side and into the diverter valve and it all clear.

E9FE4F49-3215-4AD8-9760-13726EB01496.jpeg
 

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
Is it possible to not use the cat?
I have my original cat and I knocked out all the honey comb it’s empty so basically open flow. The exhaust is no longer turning cherry red engine runs fine for about 15 min then starts the bogging or rough running.
 
  • Like
Reactions: BIG WOOD

hogjowl

Idiot™
Joined
Oct 7, 2006
Messages
48,180
Location
Prattville, Alabama
Until that old fart gets here, let me say there’s Dixie Steamway in Anniston.
There’s a TCS/Legends distributor in Pelham.
There’s Darrin Hickman’s place in Nashville -Janitorial and Restoration Hub.
I think there’s another Prochem dealer in Tuscaloosa.
Go on Sapphire and Prochem sites and do a dealer search.
 

BIG WOOD

The Timminator
Joined
Feb 4, 2016
Messages
13,412
Location
Georgia
Name
Matt w.
Until that old fart gets here, let me say there’s Dixie Steamway in Anniston.
There’s a TCS/Legends distributor in Pelham.
There’s Darrin Hickman’s place in Nashville -Janitorial and Restoration Hub.
I think there’s another Prochem dealer in Tuscaloosa.
Go on Sapphire and Prochem sites and do a dealer search.
Eh on Dixie steamway. If they have the same management and techs working there since ‘08, you might want to go elsewhere.
 

BIG WOOD

The Timminator
Joined
Feb 4, 2016
Messages
13,412
Location
Georgia
Name
Matt w.
I don’t guess there’s a supplier in our industry that doesn’t have their detractors. Don’t you dislike TCS too?
I don’t think they did anything wrong besides giving me a high price on a tm, which really isn’t bad.
 

AJR

Supportive Member
Joined
Mar 7, 2011
Messages
524
Location
n Al
Name
Whatshisbutt
Until that old fart gets here, let me say there’s Dixie Steamway in Anniston.
There’s a TCS/Legends distributor in Pelham.
There’s Darrin Hickman’s place in Nashville -Janitorial and Restoration Hub.
I think there’s another Prochem dealer in Tuscaloosa.
Go on Sapphire and Prochem sites and do a dealer search.
I will cal Robert at Dixie Monday and see if they might have any idea. The 1.6 l Vortec on these units is no longer in production and the ones available are high. Psi produces them and you need a computer diagnostics to read the computer. Hopefully they have the right equipment to diagnose and not just throw parts at it.
 

Zaccattack95

Member
Joined
Mar 30, 2020
Messages
42
Location
Grant, Michigan
Name
Zacchary Allerding
Sounds like it needs a tune up. ( new coil packs and plugs/wires and clean mass airflow sensor. I’ve replaced cats that have been cherry red in 3/4 ton 6.0 vortec pickups due to misfire. All the Unburned fuel toasts the cats and the rapid cool down will also Crack the insides along with the extreme heat. Also determine that your thermostat is not stuck open. engine would be using more fuel to make up temperature.
 
Last edited:
  • Like
Reactions: scotty747

Old Coastie

Supportive Member
Joined
Jun 29, 2015
Messages
7,504
Location
Heart of Dixie
Name
Stephen
I will cal Robert at Dixie Monday and see if they might have any idea. The 1.6 l Vortec on these units is no longer in production and the ones available are high. Psi produces them and you need a computer diagnostics to read the computer. Hopefully they have the right equipment to diagnose and not just throw parts at it.
If you need a ride home, let me know. It will cost you a large coffee from McDonald’s. I’ll take Advantage of the chance to pick up some pipe tobacco at The Humidor on my way back.
 
  • Like
Reactions: AJR and Desk Jockey

BIG WOOD

The Timminator
Joined
Feb 4, 2016
Messages
13,412
Location
Georgia
Name
Matt w.
I think this thread just cursed my truck. My cat started rattling today😡. Going to the shop tomorrow.
 
Back
Top Bottom